WSL2 - Datalore Enterprise on Ubuntu using Docker Compose

The webserver is running. I can’t execute any cells in the Getting Started Tutorial - I see an error in the gui called ‘Can’t Start the Machine’ and I see lots of errors and warnings in the Docker Compose logs related to computational resources failing.

I don’t think it is related to WSL2 - I had exactly the same set of problems running it in an Oracle Virtual Machine on Kali.

Anyone have this experience?

I do notice in the web GUI on the bottom right under the error message itself there are some details on the machine - which I assume is a Docker container that spins up when a cell executes - those details such as CPU, free mem and storage are all blank. Is it possible there is a permissions issue for my docker daemon, or a permissions issue for Datalore itself? I tried executing Docker Compose under sudo but that didn’t make any difference.

I solved it. Not 100% sure how but I basically docker rm each container, and then re-ran docker compose up, and now it works.