Trying to attach a Google Cloud Storage bucket

I just started using Datalore (and loved the experience so much that went ahead and signed up for Pro right away). Kudos to Jetbrains on creating another steller product.

But I’m having trouble attaching GCS buckets. The documentation seems a bit sparse. All that I could find is here, which simply says:

In the New datasource dialog, fill in the fields and click Save and close.

Now here’s that dialog and I’m not sure what exactly to put where.

What I tried

GCS datasource name
I believe it’s for reference within Datalore? So I can put anything here, right? Anyway, I put “patant-data-ors”.

Options I tried:

  1. patent-data-ors (name of the bucket)

Also tried 2 and 3 with https://.

I left it blank. Guessing it’s for private buckets? Mine is publicly accessible.

I couldn’t find anything in this forum on GCS. I’ll appreciate any help pointiing out what I’m doing wrong. Thank you.


Could you please check one more time? We recently deployed a fix to GCS buckets mounting, so maybe it will resolve the issue with public bucket connection as well.

Could you provide a step by step guide on how to attach a GCS bucket. I am gettting a “Succeeded” message when testing the connection but “not mounted” when trying to access the bucket from the notebook.