TOC show nothing in docker mode

I set up and run in docker mode, everything seems OK, however, the TOC never show anythig whatever i do, even opening the tutorial notebook.
could somebody help out?

Hello @leonli,

Which version do you use? I didn’t manage to reproduce this issue on 2023.1. Please also check browser console and server log for errors.

Thank you!

Best regards,
Igor Medovolkin
QA Engineer in Datalore

Hi igro,

I did get some errors reported in browser console no matter which browser I used.
pls find the related info below:

docker ps result

CONTAINER ID   IMAGE                                COMMAND                  CREATED          STATUS          PORTS                                                                                                                             NAMES
38f79b50f2fc   jetbrains/datalore-agent:2023.1      "/bin/bash agent_ent…"   10 minutes ago   Up 10 minutes 
126726d17f83   jetbrains/datalore-postgres:2023.1   "docker-entrypoint.s…"   3 weeks ago      Up 6 days       5432/tcp                                                                                                                          datalore-postgresql-1
3837c832a1a2   jetbrains/datalore-server:2023.1     "/bin/bash entrypoin…"   3 weeks ago      Up 6 days       4060/tcp, 5050/tcp, 8081/tcp,>8080/tcp, :::18082->8080/tcp                                                         datalore-datalore-1                                                                                                                                    
  • error in browser console (chrome - Version 111.0.5563.64 (Official Build) (x86_64))
    I tried open notebook in both inside and outside the VM using chrome(also safari and firefox)

Error in Chrome

worker.js?v=342:12068 Uncaught DOMException: Failed to execute 'importScripts' on 'WorkerGlobalScope': The script at '' failed to load.
    at listener (

any other info needed, pls tell me.

1 Like

Thank you for the provided details! I managed to reproduce this issue by changing the port on my installation (it worked fine on 8080, and it works fine at our other instances behind a reverse proxy).

I will forward this report to the dev team, thank you for the report!

Hi igro,

Thanks for reply, according to your comment, I changed the port back to 8080, and it works now, it really save my time.
And hope changing the port mapping will work in the future.

1 Like