Proxy configuration for pip


I would like to ask you how to configure proxy address for pip in case of a Datalore Enterprise version installed in closed network environment where only specific urls are permitted by a proxy.

In this time I’m able to install packages by setting os.environ[‘http_proxy’] =A.B.C.D:port in one cell and after that in next cell(s) I can use magic command !pip install something, but this is not persistent unfortunately.

Is there any possibility how to configure it for all users in Datalore Enterprise at once?

Thanks a lot.

It looks like I found a partly solution. I added proxy settings to an agents-config.yaml file and I modified a little an environment.yml file for new dependencies and it works. But - I have still some problems. An explore tab in Environment is not working. I could see dependencies in an Installed tab, but I’m not able to get info for a selected package (and update for instance)…

Any idea? I think that all is based on the fact that the Datalore does not fully support http(s) proxy.

Have a nice day

Hi Tomas,

I’m having the same challenge, but trying to use our own PyPi repo/proxy. With an custom agent image with an custom pip.conf, I managed to come just as far as you. Magic command works, terminal works and environment.yml works, but the UI doesn’t work. The same I had with using proxy settings.

What I can see in our logging is that datalore-server asks for information about the package to the datalore-agent. It gives a Connect timed out. From the agent container I can connect to my repo and proxy without any problems.

I’m also looking for ideas to get this working.

BTW. I’m still struggling to get the datasources working, did you manage that?

Hi Adrie,

same to me in case of data sources. I will try new version if there is any change - we will see.

Have a nice day