Problems connecting to any databases


Have Datalore running off Docker Compose. Only been using it for 2 days - love it.

However, having absolutely no luck connecting to any databases. Have tried an Azure SQL database - it works perfectly from my old Juptyer notebook using the following string:

connection = pyodbc.connect(‘Driver={ODBC Driver 17 for SQL Server};Server=’+server+‘,1433;Database=’+database+‘;Uid=’+username+‘;Pwd=’+password+‘;Encrypt=yes;TrustServerCertificate=no;Connection Timeout=30;Authentication=ActiveDirectoryInteractive’)
cursor = connection.cursor()

However, using both the Azure SQL Server and SQL Server database connection builders, I am getting a fail. I have tested pinging from the docker container and that works - can ping the server. I am also wondering - Datalore doesn’t seem to have any dialogue for handling MFA where it is needed? How does that happen?

I also tried testing to the trial postgress database in your documentation - that also failed to connect. Either I am doing something wrong or the software is…

Settings for that were as per the doc:

driver: postgresql
port: 5432
database: datalore
user: datalore
password: datalore

Any help would be appreciated. I love the product so far. Just want to get off CSV!

Is there anyone that has had this problem? It is super frustrating. I simply cannot connect to any database. I have tried the Postgress DB in the documentation, and I have tried the Azure SQL DB that I do most of my work on, and I have even run up a SQL Database on a Docker Container on my localhost.

I can connect to all of them with SSMS. I can connect to all of them with my ODBC Python connection script. I simply cannot find a way to connect to any of them with Datalore. I am either doing something badly wrong, or the database connection does not work for some reason. Is there not a list of common things I can try somewhere?

Any help would be appreciated. I have wasted 2 nights on this at this point.