Missing cells when updating a report

When updating a Build report, per default new cells are not selected for publishing. I assume that the standard case is to publish the whole notebook, which makes it very unintuitive and error-prone to update only a subset of available cells. At the moment one needs to select “hide all cells” and then “show all cells” before updating a notebook build report which should be published completely.

I think a good solution would be to have a second user option “publish all cells”, “publish inputs”, “publish outputs” and “custom selection”. an only if the latter is selected allow the user to select individual cells.

Hi Lumbric,

Thank you for the suggestion.
We have similar ideas about improving report builder.