Kernel starting is too long

I opened my notebook and started the first cell. It took about 2-4 minutes to set up the environment.

After that, I tried to install geopy via pip. The installation process started and lasted an unusually long time until it fell with exceeding available memory error. The computation restarted automatically and did not finish in 5–7 min. So I tried to restart the computation manually, reload the page, restart the browser, but the kernel did not set up in the usual time. After 10–15 min, the kernel started successfully.

I raise this problem because yesterday the environment started in a few seconds, but today and several days ago I had this problem.

Hello,

Thanks for letting us know! I’ll try to investigate the issue further, but It’s not completely clear from the log what have caused it, also everything seems to be OK at the moment – I was able to start the agent, install the library and execute the sample within a minute.

Please send us a message if the issue happens again and provide some more details (at least it would be handy to have a link to the notebook) – feel free to use our address contact at datalore.jetbrains.com.

Thanks again for the report and sorry for the inconvenience.