Disable Long Computations

Hi everyone, I’m new to DL and while testing its features I enabled Long Computation. Now I wanna go back to Live Computation just to make sure my code is not running in background when I leave but nothing happens when I select Live Computation in the menu. I’ve already tried stopping computation, interrupting the kernel, etc. before switching but nothing worked.
Any hints before I delete my notebook and re-create it from scratch?

Hi Franco!

Thank you for the feedback, it seems that our terminology is a bit confusing here. Long computation and Live computation are not opposites.

To turn off long computation, just click the “Long computation” menu item again:

When there is no tick, the long computation is turned off.

Another option to check if there is something running at the moment is the “Running computations” dialog it’s also possible to stop notebooks from it


Live computation is a special reactive computational mode available in Datalore kernel, it doesn’t affect the notebook lifecycle. When it’s turned on the notebook is immediately recalculated on changes.

1 Like

Duh! how come I didn’t see that, it was so obvious! Thank you so much, I followed your instructions and disabled Long Computations successfully.

With the latest releases the “Live Computation” option has been renamed to “Reactive Mode”. We hope it will reduce the confusion and be a more appropriate name for this mode.

Thank you for asking! It helped us to improve.