Datalore Enterprise On-premises WebSocketError


I’m having some troubles accessing datalore from the public URL. After a successful login, the a “We had an unexpected failure” page appears. From Chrome dev tools, it seems that the problem is due to the websockets. As a side note, a colleague using a Safary from MacOS does not get any error. [ see snapshot with the error I face]

Any idea on how to address this issue?

Thanks you in advance for your help!

Hello @Alvarin322,

Could you please also try accessing Datalore using Incognito mode in your browser? Given that your colleagues is able to use the application with no issues, it seems to be a client-side related problem.

Also, description for code 1006:

1006 is a reserved value and MUST NOT be set as a status code in a
      Close control frame by an endpoint.  It is designated for use in
      applications expecting a status code to indicate that the
      connection was closed abnormally, e.g., without sending or
      receiving a Close control frame.

Thank you!

Best regards,
Igor Medovolkin
QA Engineer in Datalore

Hi @igro,
thanks for your response!

Unfortunately, no difference :frowning:

This is a screenshot of the docker-compose-datalore-1 container’s log - in case it helps:


Thanks for the info!

Do you use proxy? Could you please also check wether Datalore cloud ( works fine for you? If nothing helps, please send me your server configs via DM (please remove secrets beforehand).

Yes, I am using a proxy!

I tried datalore cloud and that works fine (login, executing code cells and similar).

I am sending you a DM as well.

Thanks again for your support!

I am using Datalore server in docker behind nginx reverse proxy with SSL termination on nginx. I had the same error. The fix is to add “DATALORE_PUBLIC_URL” env variable to your Datalore compose file and set the value to the full URL including PORT number.